|ACTIVITYPUB(7)||Miscellaneous Information Manual||ACTIVITYPUB(7)|
notes about the honk implementation
The honk(1) utility
processes status updates and other microblog activities using the
ActivityPub protocol to exchange messages with other
servers. The specification is subject to interpretation, and not all
implementations behave in the same way. This document attempts to clarify
honk's behavior. It is not intended to be a complete description of
ActivityPub, but may be useful as a guide to other
implementors looking to interoperate.
The following object or document types are supported.
- Fully supported. The default object type for honk.
- Fully supported.
- Read only support. Appears similar to a Note.
- Supported. Appears similar to a Note. Can be both created and received, but Invite activities are ignored.
- Limited support.
- Limited Support.
- Guess the word game. (Unofficial extension.) The solution is stored in content with the possible words, one per line, in a file located at wordlist.
Honk primarily supports HTML content, not markdown or other formats, with a wide range of permitted HTML tags in object content fields. The following tags are supported.
a, img, span, div, h1, h2, h3, h4, h5, h6, hr, table, thead, tbody, tfoot, th, tr, td, colgroup, col, p, br, pre, code, blockquote, q, caption, kbd, time, wbr, aside, ruby, rtc, rb, rt, details, summary, samp, mark, ins, dfn, cite, abbr, address, strong, em, b, i, s, u, sub, sup, del, tt, small, ol, ul, li, dl, dt, dd
The following tag attributes are permitted.
href, src, alt, colspan, rowspan
The following class names are used for syntax highlighting code blocks.
kw, bi, st, nm, tp, op, cm, al, dl
The following activities are supported.
- Fully supported.
- Supported with share semantics.
- Supported. Primarily used to acknowledge replies and complete threads. Can be interpreted to mean reply is approved, if not endorsed.
- Works with collections.
- Supported. Can follow both actors and collections.
- Supported. Honk sends and receives Update activities.
- Does what it can.
- Don't be ridiculous.
- Be ridiculous.
The following additional object types are supported, typically as tag or attachment.
- Pretty @ machine.
- Inline text :emoji: with image replacement.
- Included as a location. Supports name, url, latitude, and longitude.
- Plain text and images in jpeg, gif, png, and webp formats are supported. Other formats are linked to origin.
The replies array will be populated with a list of acknowledged replies.
Honk also supports a Ping activity and will respond with a Pong activity. This is useful for debugging networking connectivity issues without visible side effects. See ping.txt for details.
Honk uses http signatures.
Honk implements the webfinger end point and will use it for @mention resolution. It is not required for federation.
The ActivityPub standard is subject to interpretation, and not all implementations are as enlightened as honk.
|December 3, 2022||OpenBSD 7.0|